4

Closed

Tracking: Show the power/compatibility of IronPython by showing Trac running on IronPython

description

I think one of the samples you should show is trac http://trac.edgewall.org/ running on IronPython. There is a lot of interest in this and it would be a sample that a lot of people could make use of (expanding the use of IronPython and showing it's compatibility at the same tune).
Closed Dec 9, 2014 at 7:36 PM by jdhardy
Migrated to GitHub.

comments

sanxiyn wrote Jun 5, 2007 at 8:08 PM

wrote Jun 7, 2007 at 11:33 PM

wrote Jul 26, 2007 at 4:33 PM

wrote Sep 12, 2007 at 8:30 PM

wrote Sep 12, 2007 at 8:40 PM

wrote Sep 12, 2007 at 8:53 PM

wrote Sep 14, 2007 at 10:06 PM

We would like to get specific bugs that we can investigate.

wrote Oct 5, 2007 at 12:18 AM

slide_o_mix wrote Mar 12, 2012 at 10:56 PM

See [workitem:32400] for one issue found during install.

slide_o_mix wrote Mar 25, 2012 at 10:45 PM

Looks like trac requires expat (because trac requires genshi which requires expat).

Traceback (most recent call last):
File "C:\IronPython-2.7.2.1\lib\site-packages\setuptools-0.6c11-py2.7.egg\pkg_
resources.py", line 318, in load_entry_point
File "C:\IronPython-2.7.2.1\lib\site-packages\setuptools-0.6c11-py2.7.egg\pkg_
resources.py", line 1954, in load
File "C:\IronPython-2.7.2.1\lib\site-packages\trac-0.12.3-py2.7.egg\trac\admin
__init__.py", line 14, in <module>
File "C:\IronPython-2.7.2.1\lib\site-packages\trac-0.12.3-py2.7.egg\trac\admin
\api.py", line 19, in <module>
File "C:\IronPython-2.7.2.1\lib\site-packages\trac-0.12.3-py2.7.egg\trac\util\
init.py", line 35, in <module>
File "C:\IronPython-2.7.2.1\lib\site-packages\trac-0.12.3-py2.7.egg\trac\util\
text.py", line 30, in <module>
File "C:\IronPython-2.7.2.1\Scripts\trac-admin", line 7, in <module>
File "C:\IronPython-2.7.2.1\lib\site-packages\setuptools-0.6c11-py2.7.egg\pkg_
resources.py", line 2221, in load_entry_point
File "C:\IronPython-2.7.2.1\lib\site-packages\trac-0.12.3-py2.7.egg\trac\util\
translation.py", line 19, in <module>
File "C:\IronPython-2.7.2.1\lib\site-packages\genshi-0.6-py2.7.egg\genshi__in
it__.py", line 26, in <module>
File "C:\IronPython-2.7.2.1\lib\site-packages\genshi-0.6-py2.7.egg\genshi\inpu
t.py", line 22, in <module>
ImportError: cannot import expat from xml.parsers

wrote Apr 30, 2012 at 3:26 PM

wrote Feb 22, 2013 at 1:16 AM

wrote Dec 9, 2014 at 7:36 PM