3

Closed

Unable to find dependency 'MICROSOFT.SCRIPTING.METADATA' (Signature='7F709C5B713576E1' Version='1.1.0.20') of assembly 'Microsoft.Dynamic.dll'

description

I am using Visual Studio 2010 Professional SP1 on Windows 7 Pro SP1 32-bit Virtual Machine. Brand new VM I installed today, so it is clean.

I downloaded the IronPython 2.7.3 binaries.
When I unzip them, I view the Details by right-clicking the DLL in Windows Explorer and selecting Properties.
I see the File Version for Microsoft.Dynamic.dll and Microsoft.Scripting.DLL are both 1.1.0.21.
I added the DLLs as References to a project, Copy Local = True. When I look at the Version of Microsoft.Dynamic.DLL and Microsoft.Scripting.DLL in the Properties window, they both say 1.1.0.20.

I added a setup project to my solution, and when I View > File System and select Application Folder, I have confirmed that I specified the Primary output of the project.
When I build the setup project, the following warning occurs:
Warning 1 Unable to find dependency 'MICROSOFT.SCRIPTING.METADATA' (Signature='7F709C5B713576E1' Version='1.1.0.20') of assembly 'Microsoft.Dynamic.dll' C:\X\Server\X.Server.WindowsServiceSetup\X.Server.WindowsServiceSetup.vdproj X.Server.WindowsServiceSetup

1) How can I stop this warning? (Why can't it find the DLL?)
2) Why does it say 1.1.0.20 instead of 1.1.0.21?

I am not allowed to install IronPython.
I am not allowed to have any warnings.

Please help.
Closed Dec 9 at 8:58 PM by jdhardy
Migrated to GitHub,

comments

florianisopp wrote Aug 29, 2013 at 11:06 AM

I struggled with the same issue several weeks. It came up from time to time and I didn't know why and what it was..
__
Solution:__
I downgraded complete IronPython to version 2.7.1 :
https://ironpython.codeplex.com/releases/view/62475

This one uses Microsoft.Dynamic.dll 1.1.0.20

Works for me!